aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-traitlets/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-traitlets/APKBUILD')
-rw-r--r--community/py3-traitlets/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/py3-traitlets/APKBUILD b/community/py3-traitlets/APKBUILD
new file mode 100644
index 0000000000..b938eefcd1
--- /dev/null
+++ b/community/py3-traitlets/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=py3-traitlets
+pkgver=4.3.2
+pkgrel=1
+pkgdesc="A lightweight Traits like module"
+url="https://traitlets.readthedocs.io/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py-six py3-ipython_genutils"
+makedepends="python3-dev"
+options="!check" # No test suite present
+source="traitlets-$pkgver.tar.gz::https://github.com/ipython/traitlets/archive/$pkgver.tar.gz"
+builddir="$srcdir/${pkgname#py3-}-${pkgver}"
+replaces="py-traitlets"
+provides="py-traitlets"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="74963f3f0c25dce9c734585b09416bf58350e51714497b024f7e261da9cfd82a7517d42b09920c014d367494e656a4ed76790c711a384d85bfde2ae6fffeaa34 traitlets-4.3.2.tar.gz"