aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-traitlets/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-traitlets/APKBUILD')
-rw-r--r--community/py3-traitlets/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/community/py3-traitlets/APKBUILD b/community/py3-traitlets/APKBUILD
index 3b24b44042..70ec61e853 100644
--- a/community/py3-traitlets/APKBUILD
+++ b/community/py3-traitlets/APKBUILD
@@ -2,18 +2,19 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-traitlets
pkgver=4.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="A lightweight Traits like module"
url="https://traitlets.readthedocs.io/"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py-six py3-ipython_genutils"
-makedepends="python3-dev"
+makedepends="py3-setuptools"
options="!check" # No test suite present
source="traitlets-$pkgver.tar.gz::https://github.com/ipython/traitlets/archive/$pkgver.tar.gz"
-builddir="$srcdir/${pkgname#py3-}-${pkgver}"
-replaces="py-traitlets"
-provides="py-traitlets"
+builddir="$srcdir/${pkgname#py3-}-$pkgver"
+
+replaces="py-traitlets" # Backwards compatibility
+provides="py-traitlets=$pkgver-r$pkgrel" # Backwards compatibility
build() {
python3 setup.py build