aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ukpostcodeparser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ukpostcodeparser/APKBUILD')
-rw-r--r--community/py3-ukpostcodeparser/APKBUILD49
1 files changed, 12 insertions, 37 deletions
diff --git a/community/py3-ukpostcodeparser/APKBUILD b/community/py3-ukpostcodeparser/APKBUILD
index 7fa0d32cb2..c89b9cb9f2 100644
--- a/community/py3-ukpostcodeparser/APKBUILD
+++ b/community/py3-ukpostcodeparser/APKBUILD
@@ -1,57 +1,32 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=py-ukpostcodeparser
+pkgname=py3-ukpostcodeparser
_pkgname=ukpostcodeparser
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="UK Postcode parser"
-url=https://github.com/hamstah/ukpostcodeparser
-arch=noarch
-license=MIT
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-makedepends="py-setuptools python2-dev python3-dev"
+url="https://github.com/hamstah/ukpostcodeparser"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/hamstah/$_pkgname/archive/v$pkgver.tar.gz"
-builddir=$srcdir/$_pkgname-$pkgver
+builddir="$srcdir/$_pkgname-$pkgver"
# tests broken upstream: https://github.com/hamstah/ukpostcodeparser/issues/8
options="!check"
-prepare() {
- cp -r "$builddir" "$builddir"-py3
-}
+replaces="py-ukpostcodeparser" # Backwards compatibility
+provides="py-ukpostcodeparser=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
- python2 setup.py build
- cd "$builddir"-py3
python3 setup.py build
}
check() {
- cd "$builddir"
- python2 setup.py test
- cd "$builddir"-py3
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- cd "$builddir"
- _py python2
-}
-
-_py3() {
- cd "$builddir"-py3
- _py python3
-}
-
-_py() {
- python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="8113522b728c095f937a9f53f21c369130e3e63c4fc3546dbea4ad1c53648742fb0e766b1254c76ee65d69dec585f1a90caa7d39ca540de1765ff5f989a702de py-ukpostcodeparser-1.1.2.tar.gz"
+sha512sums="8113522b728c095f937a9f53f21c369130e3e63c4fc3546dbea4ad1c53648742fb0e766b1254c76ee65d69dec585f1a90caa7d39ca540de1765ff5f989a702de py3-ukpostcodeparser-1.1.2.tar.gz"