aboutsummaryrefslogtreecommitdiffstats
path: root/community/restic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/restic/APKBUILD')
-rw-r--r--community/restic/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/community/restic/APKBUILD b/community/restic/APKBUILD
index f72df0f61b..d20d47a8ce 100644
--- a/community/restic/APKBUILD
+++ b/community/restic/APKBUILD
@@ -8,11 +8,11 @@ url="https://restic.net/"
arch="all"
license="BSD-2-Clause"
makedepends="go"
-options="net !checkroot"
+options="net"
subpackages="$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
-source="https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/restic/restic/releases/download/v$pkgver/restic-$pkgver.tar.gz"
builddir="$srcdir/src/github.com/$pkgname/$pkgname"
export GOPATH="$srcdir"
@@ -24,17 +24,14 @@ prepare() {
}
build() {
- cd "$builddir"
go build ./cmd/...
}
check() {
- cd "$builddir"
RESTIC_TEST_FUSE=0 make test
}
package() {
- cd "$builddir"
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
local man