aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust
diff options
context:
space:
mode:
Diffstat (limited to 'community/rust')
-rw-r--r--community/rust/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index bf4d63ee68..b3424810d0 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -77,10 +77,12 @@ build() {
--local-rust-root="/usr" \
--llvm-root="/usr/lib/llvm$_llvmver" \
--musl-root="/usr" \
- --enable-vendor \
+ --disable-docs \
--enable-llvm-link-shared \
- --disable-jemalloc \
- --disable-docs
+ --enable-option-checking \
+ --enable-locked-deps \
+ --enable-vendor \
+ --disable-jemalloc
RUST_BACKTRACE=1 \
RUSTC_CRT_STATIC="false" \