aboutsummaryrefslogtreecommitdiffstats
path: root/community/uhttpmock/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/uhttpmock/APKBUILD')
-rw-r--r--community/uhttpmock/APKBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/community/uhttpmock/APKBUILD b/community/uhttpmock/APKBUILD
index e50ab10c60..2137ab7358 100644
--- a/community/uhttpmock/APKBUILD
+++ b/community/uhttpmock/APKBUILD
@@ -12,19 +12,10 @@ install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://tecnocode.co.uk/downloads/uhttpmock/$pkgname-$pkgver.tar.xz"
-_builddir="$srcdir"/uhttpmock-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/uhttpmock-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,7 +30,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}