aboutsummaryrefslogtreecommitdiffstats
path: root/community/zfs-auto-snapshot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/zfs-auto-snapshot/APKBUILD')
-rw-r--r--community/zfs-auto-snapshot/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/zfs-auto-snapshot/APKBUILD b/community/zfs-auto-snapshot/APKBUILD
new file mode 100644
index 0000000000..433f13df51
--- /dev/null
+++ b/community/zfs-auto-snapshot/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
+pkgname=zfs-auto-snapshot
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="ZFS Automatic Snapshot Service for Linux"
+url="https://github.com/zfsonlinux/zfs-auto-snapshot"
+arch="noarch !armhf !armv7" # limited by zfs
+license="GPL-2.0-or-later"
+depends="zfs"
+checkdepends="checkbashisms"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zfsonlinux/zfs-auto-snapshot/archive/upstream/$pkgver.tar.gz
+ 0001-alpine.patch
+ "
+builddir="$srcdir/$pkgname-upstream-$pkgver"
+
+check() {
+ checkbashisms src/zfs-auto-snapshot.sh
+}
+
+package() {
+ make install PREFIX="/usr" DESTDIR="$pkgdir"
+}
+
+sha512sums="26382303fce8b90dfb40f69fcab92308e88c17c147b4a566c5d32f2e9aa241d64f5da56ad82b4becb824ba01a470037a724460d35676a1d46de9c578c02a57d9 zfs-auto-snapshot-1.2.4.tar.gz
+76733b98a168fa0a09452809aad5e1079cf789e5c96f5ced590b3e8d609c26b2fedc38ca0b406544825cd509f259df8e917d4b1355f8bea9942b0ca0ba872eba 0001-alpine.patch"