aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/xbps/APKBUILD7
-rw-r--r--community/xbps/disable-Werror.patch13
2 files changed, 18 insertions, 2 deletions
diff --git a/community/xbps/APKBUILD b/community/xbps/APKBUILD
index 70e717bc7c..44852997cc 100644
--- a/community/xbps/APKBUILD
+++ b/community/xbps/APKBUILD
@@ -13,7 +13,9 @@ subpackages="$pkgname-dev $pkgname-doc
$pkgname-bash-completion:bashcomp:noarch
$pkgname-zsh-completion:zshcomp:noarch"
options="!check"
-source="$pkgname-$pkgver.tar.gz::https://github.com/voidlinux/$pkgname/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/voidlinux/$pkgname/archive/$pkgver.tar.gz
+ disable-Werror.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -59,4 +61,5 @@ _submv() {
mv "$pkgdir"/$path "$subpkgdir"/${path%/*}/
}
-sha512sums="99a86abac4e8c3a7e4d6bb72c78a1c1b72592022ab0f90f794227d8fa6194a04e0411fcedc4fffb6809dcf146aa6e7f9b12e3a9854e024458f1b9c4573b7379d xbps-0.52.tar.gz"
+sha512sums="99a86abac4e8c3a7e4d6bb72c78a1c1b72592022ab0f90f794227d8fa6194a04e0411fcedc4fffb6809dcf146aa6e7f9b12e3a9854e024458f1b9c4573b7379d xbps-0.52.tar.gz
+a761edd8fd358b500337fcef79f6163ef642fc387f97d952fec0838baa786d585f21e34cd066cba1918f474bccd7decbad2587b91f125b75e308b2dfe8f4721a disable-Werror.patch"
diff --git a/community/xbps/disable-Werror.patch b/community/xbps/disable-Werror.patch
new file mode 100644
index 0000000000..a572b0580e
--- /dev/null
+++ b/community/xbps/disable-Werror.patch
@@ -0,0 +1,13 @@
+diff --git a/configure b/configure
+index 9bff5d5..cc5d2ce 100755
+--- a/configure
++++ b/configure
+@@ -266,7 +266,7 @@ fi
+ #
+ # Check for some compiler warning flags.
+ #
+-for f in all extra error shadow "format=2" missing-prototypes \
++for f in all extra shadow "format=2" missing-prototypes \
+ missing-declarations nested-externs vla no-overlength-strings \
+ unsafe-loop-optimizations undef sign-compare \
+ missing-include-dirs old-style-definition \