aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/ansible-lint/10-python3-shebang.patch8
-rw-r--r--community/ansible-lint/APKBUILD34
-rw-r--r--community/py3-ruamel.std.pathlib/APKBUILD32
-rw-r--r--community/py3-ruamel.yaml/APKBUILD47
4 files changed, 121 insertions, 0 deletions
diff --git a/community/ansible-lint/10-python3-shebang.patch b/community/ansible-lint/10-python3-shebang.patch
new file mode 100644
index 0000000000..1493a7a6a6
--- /dev/null
+++ b/community/ansible-lint/10-python3-shebang.patch
@@ -0,0 +1,8 @@
+--- a/bin/ansible-lint
++++ b/bin/ansible-lint
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ import sys
+ import ansiblelint.__main__
diff --git a/community/ansible-lint/APKBUILD b/community/ansible-lint/APKBUILD
new file mode 100644
index 0000000000..833fb6c586
--- /dev/null
+++ b/community/ansible-lint/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=ansible-lint
+pkgver=4.1.0
+pkgrel=0
+pkgdesc="A tool to check ansible playbooks"
+url="https://github.com/ansible/ansible-lint"
+arch="noarch"
+license="MIT"
+depends="ansible py3-yaml py3-six py3-ruamel.yaml py3-setuptools"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/a/$pkgname/$pkgname-$pkgver.tar.gz
+ 10-python3-shebang.patch
+ "
+provides="py3-ansible-lint=$pkgver-r$pkgrel" # for backward compatibility
+replaces="py3-ansible-lint" # for backward compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+sha512sums="320d0e544b2d0097f1a27b84d3abd0719096b643d77f0c920fdb07d3a40cc7fd967a36979c5a9700c53370ad86e516e35666a00224b2ca9661373de95dbc8106 ansible-lint-4.1.0.tar.gz
+4a8dbbc51f686985ba857aff4063c8f2078af4d9b4134d799017cca958d85e59e0f9985f8e1bb16c6e1110f2586119d33c31364e31722b343de15376e4a8dd2d 10-python3-shebang.patch"
diff --git a/community/py3-ruamel.std.pathlib/APKBUILD b/community/py3-ruamel.std.pathlib/APKBUILD
new file mode 100644
index 0000000000..d78437ea3c
--- /dev/null
+++ b/community/py3-ruamel.std.pathlib/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=py3-ruamel.std.pathlib
+_pyname=ruamel.std.pathlib
+pkgver=0.6.3
+pkgrel=0
+pkgdesc="improvements over the standard pathlib module and pathlib2 package"
+url=https://bitbucket.org/ruamel/std.pathlib
+arch=noarch
+license=MIT
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="$_pyname-$pkgver.tar.gz::https://bitbucket.org/ruamel/std.pathlib/get/$pkgver.tar.gz"
+# 79fff2a1baf7ae44c46415b5fac653cf4a7db9d2 0.6.3
+builddir="$srcdir/ruamel-std.pathlib-79fff2a1baf7"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONPATH=build/lib python3 -m pytest
+}
+
+package() {
+ cd "$builddir"
+ python3 -m pip install . --prefix=/usr --root="$pkgdir"
+}
+sha512sums="1210d8f7ae77c6358fc857c3ee447b2eb9802eaa31a210804acd74ec23dfd6ac9dec90dd7b21c79dcb4845dff4ad3614dd615c4798d3d7a39cc3a877cb9b63b0 ruamel.std.pathlib-0.6.3.tar.gz"
diff --git a/community/py3-ruamel.yaml/APKBUILD b/community/py3-ruamel.yaml/APKBUILD
new file mode 100644
index 0000000000..2093132d72
--- /dev/null
+++ b/community/py3-ruamel.yaml/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=py3-ruamel.yaml
+pkgver=0.15.91
+pkgrel=0
+pkgdesc="A YAML parser/emitter"
+url="https://bitbucket.org/ruamel/yaml"
+arch="all"
+license="MIT"
+replaces="py-ruamel py3-ruamel"
+provides="py-ruamel=$pkgver-r$pkgrel py3-ruamel=$pkgver-r$pkgrel"
+makedepends="python3-dev py3-setuptools"
+checkdepends="py3-pytest py3-ruamel.std.pathlib"
+source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/ruamel/yaml/get/$pkgver.tar.gz"
+# 22286ce99d6552c658cb11d0a8a3c9b962ebe510 0.15.91
+builddir="$srcdir/ruamel-yaml-22286ce99d65"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" \
+ --single-version-externally-managed
+}
+
+check(){
+ cd "$builddir"
+ _plat_specifier="$(python3 <<-EOF
+ from distutils.util import get_platform
+ from sys import version_info
+
+ print("{}-{}.{}".format(get_platform(), *version_info))
+ EOF
+ )"
+ PYTHONPATH="build/lib.$_plat_specifier" python3 -m pytest \
+ --deselect=_test/test_issues.py::TestIssues::test_issue_82 \
+ --deselect=_test/test_issues.py::TestIssues::test_issue_220 \
+ --deselect=_test/test_issues.py::TestIssues::test_issue_238 \
+ --deselect=_test/test_yamlobject.py::test_monster \
+ --deselect=_test/test_yamlobject.py::test_qualified_name00 \
+ _test/test_*.py
+}
+
+sha512sums="c9c9de649a40cb55953005a2fa991112c34a699409379c3c04d33f9f42efa7d0e43fb4c7e7f5caea1b6a86af4e0785925c541632bca88ab6b9c52969260b705a py3-ruamel.yaml-0.15.91.tar.gz"