aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libbluray/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/libbluray/APKBUILD b/community/libbluray/APKBUILD
new file mode 100644
index 0000000000..015cccaf43
--- /dev/null
+++ b/community/libbluray/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=libbluray
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="Library for Blu-Ray disc playback"
+url="https://www.videolan.org/developers/libbluray.html"
+arch="all"
+license="LGPL-2.1-or-later"
+subpackages="$pkgname-dev"
+source="https://download.videolan.org/pub/videolan/libbluray/$pkgver/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-bdjava \
+ --without-libxml2 \
+ --without-freetype \
+ --disable-bdjava-jar
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e1360ad08aa6cc67a80efa81a09004faebbe31105f1961494f82f655e3e7378b198ee3bc534b0d0c2bfec726939b11b545cc8bbfa30794fc647432dadf71089b libbluray-1.0.2.tar.bz2"