aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/py3-lupa/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/py3-lupa/APKBUILD b/community/py3-lupa/APKBUILD
new file mode 100644
index 0000000000..2e5a746a33
--- /dev/null
+++ b/community/py3-lupa/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=py3-lupa
+_pkgname=${pkgname#py3-}
+pkgver=1.8
+pkgrel=1
+pkgdesc="Python wrapper around Lua and LuaJIT"
+url="https://pypi.org/project/lupa/"
+arch="all"
+license="MIT"
+makedepends="python3-dev"
+depends="python3"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="!check" # no test suite
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="322da16f11e5f2a76c39d3ebf3582b517b798df6bfd87f0e08038f1c5b180279a59cdf0688e5ec86ab50a7732d6ab4767e0798f6b864654a247767fad6bf56dd py3-lupa-1.8.tar.gz"