aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/php5/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/php5/APKBUILD b/community/php5/APKBUILD
index 3cef710fa0..c656dfd367 100644
--- a/community/php5/APKBUILD
+++ b/community/php5/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=php5
pkgver=5.6.38
-pkgrel=0
+pkgrel=1
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
arch="all"
@@ -167,6 +167,10 @@ _do_build() {
cd "$_builddir"
export EXTENSION_DIR=$_extdir
export PEAR_INSTALLDIR="$_peardir"
+
+ #http://source.icu-project.org/repos/icu/trunk/icu4c/readme.html#RecBuild
+ export CPPFLAGS="$CPPFLAGS -DU_USING_ICU_NAMESPACE=1"
+
"$_srcdir"/configure $@ || return 1
sed -ri "s/^(EXTRA_LDFLAGS[ ]*\=.*)/\1 -lpthread/" Makefile # see #183
make || return 1