aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/ruby-ox/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/ruby-ox/APKBUILD b/community/ruby-ox/APKBUILD
index c644c0c750..86d0f079db 100644
--- a/community/ruby-ox/APKBUILD
+++ b/community/ruby-ox/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-ox
_gemname=${pkgname#ruby-}
pkgver=2.8.2
-pkgrel=1
+pkgrel=2
pkgdesc="A fast XML parser and object serializer for Ruby"
url="https://github.com/ohler55/ox"
arch="all"
@@ -26,8 +26,12 @@ build() {
--verbose \
$_gemname
+ cd dist/extensions/*/*/$_gemname-*/
+
+ # ox expects ox.so to be in ox/ subdirectory, but does not install it here.
+ mkdir ox && mv *.so ox/
# Needed for tests.
- cp -l dist/extensions/*/*/$_gemname-*/*.so ext/$_gemname/
+ cp -l ox/*.so "$builddir"/ext/$_gemname/
}
check() {