aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/mypaint-brushes/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/mypaint-brushes/APKBUILD b/community/mypaint-brushes/APKBUILD
new file mode 100644
index 0000000000..b7f6d6ab5f
--- /dev/null
+++ b/community/mypaint-brushes/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sascha Paunovic <azarus@posteo.net>
+# Maintainer: Sascha Paunovic <azarus@posteo.net>
+pkgname=mypaint-brushes
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="default MyPaint brushes"
+url="https://github.com/Jehan/mypaint-brushes"
+arch="noarch"
+license="CC0-1.0"
+makedepends="autoconf automake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Jehan/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/"$pkgname-$pkgver
+
+prepare() {
+ cd "$builddir"
+ autoreconf -i
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f8e0050cd700358d75cd25e40acd73905e2a53f21c6177cf67e8012aa4fbba8dc445109f07601c3846f95532a40feff4441081c0aa4e958049fc0ed8008fb414 mypaint-brushes-1.3.0.tar.gz"