aboutsummaryrefslogtreecommitdiffstats
path: root/main/acpica/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/acpica/APKBUILD')
-rw-r--r--main/acpica/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/acpica/APKBUILD b/main/acpica/APKBUILD
index 705c3f1c21..9bd218b662 100644
--- a/main/acpica/APKBUILD
+++ b/main/acpica/APKBUILD
@@ -28,8 +28,12 @@ build() {
generate/unix/Makefile \
generate/unix/Makefile.config \
|| return 1
-
- make BITSFLAG=-m32 || return 1
+
+ case $CARCH in
+ x86_64) _bits=64;;
+ x86) _bits=32;;
+ esac
+ make BITSFLAG=-m$_bits || return 1
}
package() {