aboutsummaryrefslogtreecommitdiffstats
path: root/main/aspell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/aspell/APKBUILD')
-rw-r--r--main/aspell/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/main/aspell/APKBUILD b/main/aspell/APKBUILD
index 5e1bf88972..34cd720d4e 100644
--- a/main/aspell/APKBUILD
+++ b/main/aspell/APKBUILD
@@ -2,28 +2,29 @@
pkgname=aspell
pkgver=0.60.6
_pkgmajorver=${pkgver%.*}
-pkgrel=1
+pkgrel=2
pkgdesc="A spell checker designed to eventually replace Ispell"
url="http://aspell.net/"
license="LGPL"
subpackages="$pkgname-dev $pkgname-doc"
depends=
-makedepends="ncurses-dev uclibc++-dev perl"
+makedepends="ncurses-dev perl"
install=
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
libmath.patch"
-build ()
-{
+build() {
cd "$srcdir"/$pkgname-$pkgver
- export CXX=${CXX_UC:-g++-uc}
-
./configure --prefix=/usr || return 1
# we want add -lm to linker flag for libaspell so wil build that
# separately. this is just an ugly workaround
make libaspell.la LDFLAGS="$LDFLAGS -lm" || return 1
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
ln -s $pkgname-${_pkgmajorver} "$pkgdir"/usr/lib/$pkgname || return 1
}