aboutsummaryrefslogtreecommitdiffstats
path: root/main/build-base/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/build-base/APKBUILD')
-rw-r--r--main/build-base/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/main/build-base/APKBUILD b/main/build-base/APKBUILD
index 9ae0ceb349..c9072f3f3d 100644
--- a/main/build-base/APKBUILD
+++ b/main/build-base/APKBUILD
@@ -1,10 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=build-base
-pkgver=0.4
-pkgrel=1
+pkgver=0.5
+pkgrel=0
url=http://dev.alpinelinux.org/cgit
pkgdesc="Meta package for build base"
-depends="binutils gcc make libc-dev fortify-headers g++"
+depends="binutils gcc g++ make libc-dev fortify-headers"
+if [ "$CHOST" != "$CTARGET" ]; then
+ pkgname="$pkgname-$CTARGET_ARCH"
+ pkgdesc="$pkgdesc ($CTARGET_ARCH)"
+ depends="binutils-$CTARGET_ARCH gcc-$CTARGET_ARCH g++-$CTARGET_ARCH $depends"
+fi
arch="noarch"
license=none