aboutsummaryrefslogtreecommitdiffstats
path: root/main/gdb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gdb/APKBUILD')
-rw-r--r--main/gdb/APKBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/main/gdb/APKBUILD b/main/gdb/APKBUILD
index 01a67dcbd8..45e29c535b 100644
--- a/main/gdb/APKBUILD
+++ b/main/gdb/APKBUILD
@@ -1,12 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdb
-pkgver=8.2.1
-pkgrel=2
+pkgver=8.3
+pkgrel=0
pkgdesc="The GNU Debugger"
-url="https://www.sourceware.org/gdb/"
+url="https://www.gnu.org/software/gdb/"
arch="all"
-license="GPL-3.0"
-depends=
+license="GPL-3.0-or-later LGPL-3.0-or-later"
makedepends="ncurses-dev expat-dev texinfo readline-dev python3-dev
zlib-dev autoconf automake libtool linux-headers perl"
options="!check"
@@ -15,11 +14,8 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
s390x-use-elf-gdb_fpregset_t.patch
ppc-musl.patch
ppc-ptregs.patch
- aarch64-headers.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
-
build () {
cd "$builddir"
local _config="
@@ -43,14 +39,14 @@ build () {
# avoid generation of mangled and non-mangled objects on ppc64
[ "$CARCH" = ppc64le ] && _config="$_config --enable-build-with-cxx=no"
- ./configure $_config || return 1
- (cd opcodes && ./configure $_config) || return 1
- make || return 1
+ ./configure $_config
+ (cd opcodes && ./configure $_config)
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
# resolve conflict with binutils-doc
rm -f "$pkgdir"/usr/share/info/bfd.info
@@ -61,8 +57,7 @@ package() {
rm -rf "$pkgdir"/usr/lib
}
-sha512sums="2aa81cfd389bb48c35d7d9f95cc10e88b4f7ad4597bdde0f8f1fd312f60f10d9fb2cc6e5a9355227d89ff328f7feb0fc411a69394560cafeb9fa75d35d896d11 gdb-8.2.1.tar.xz
+sha512sums="47ac074d20a09a3fac8f4a41dce0a0cbe6ef702f7dc21ba8b7d650d306128dcae481e9a16bf65e596b3a541dc82ae57c02bcbb786d551b4ef3e2917b9b6f0ae1 gdb-8.3.tar.xz
70e7d04e4d72461436da503b5bfa370c5779e03245c521f30e9779d5ff37dbb2d708b05f2afb27f43ad9defc44df4bd979d72f777e744851fdbf156295e1cc9f s390x-use-elf-gdb_fpregset_t.patch
04911f87904b62dd7662435f9182b20485afb29ddb3d6398a9d31fef13495f7b70639c77fdae3a40e2775e270d7cd40d0cfd7ddf832372b506808d33c8301e01 ppc-musl.patch
-b75e1c1ee503a1948a7d5b8d90427b5c7d38ded69978056cee0adca222771a5c95ed1ac73127fcae7b795ea94296344eee5fca47e4cd04b418c164a756fb0933 ppc-ptregs.patch
-cd4a22a3ee10c7326edd6a6766c39110ce1400ac7499db7a2140744c05deb573498b0501aad045bccbaea4e87d45b62a758bfe134760ae49a01402697483d601 aarch64-headers.patch"
+b75e1c1ee503a1948a7d5b8d90427b5c7d38ded69978056cee0adca222771a5c95ed1ac73127fcae7b795ea94296344eee5fca47e4cd04b418c164a756fb0933 ppc-ptregs.patch"