aboutsummaryrefslogtreecommitdiffstats
path: root/main/gpsd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gpsd/APKBUILD')
-rw-r--r--main/gpsd/APKBUILD23
1 files changed, 21 insertions, 2 deletions
diff --git a/main/gpsd/APKBUILD b/main/gpsd/APKBUILD
index 0046eb9acb..691a6a2824 100644
--- a/main/gpsd/APKBUILD
+++ b/main/gpsd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Nathan Angelacos <nangel@alpinelinux.org>
pkgname=gpsd
pkgver=3.9
-pkgrel=0
+pkgrel=1
pkgdesc="A GPS daemon"
arch=all
url="http://catb.org/gpsd/"
@@ -12,6 +12,8 @@ makedepends="scons python-dev libcap-dev"
install=
# subpackages="$pkgname-doc $pkgname-dev"
source="http://download-mirror.savannah.gnu.org/releases/gpsd/$pkgname-$pkgver.tar.gz
+ gpsd-use-local-timepps-header.patch
+ timepps.h
gpsd.initd
gpsd.confd"
@@ -19,17 +21,28 @@ _builddir="$srcdir"/$pkgname-$pkgver
prepare() {
local i
+
+ # We copy timepps.h to the local build directory instead of
+ # creating a pps-tools-dev package for ppstime.h
+ # (See https://github.com/ago/pps-tools)
+ mkdir "$_builddir"/sys
+ cp timepps.h "$_builddir"/sys/
+
+
cd "$_builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+
}
build() {
cd "$_builddir"
+ CPPSFLAGS="$CPPSFLAGS -I."
export CPPFLAGS=\"$CPPFLAGS\"
+ echo $CPPFLAGS
scons -j${JOBS:-2} \
prefix=/usr \
|| return 1
@@ -39,7 +52,7 @@ package() {
cd "$_builddir"
mkdir -p "$pkgdir"/usr/lib
- cp "$_builddir"/libgps*.so* "$pkgdir"/usr/lib/
+ cp -a "$_builddir"/libgps*.so* "$pkgdir"/usr/lib/
mkdir -p "$pkgdir"/usr/sbin
for a in gpsdecode gpsd gpsctl gpsdctl gpspipe; do
@@ -51,11 +64,17 @@ package() {
}
md5sums="53a88f24a0973d23427e82e9a8914f19 gpsd-3.9.tar.gz
+2cfc595c7cbd979970f8a0dae0b7d982 gpsd-use-local-timepps-header.patch
+28f6835098a216f4a620f9218d15b5b8 timepps.h
ac2c2a034c15df16c28c755d47d3dd74 gpsd.initd
453f3d1d75d2b048f0987cfb9cf250fd gpsd.confd"
sha256sums="d9b24be838b48db5e8eba66f74edf32d1982fe0fb018c9d9a7ad1ada9f189d5a gpsd-3.9.tar.gz
+d9c9393f46ca0fa17bc37cf309092e3afef0b6008de411f08a30405e9c7b9931 gpsd-use-local-timepps-header.patch
+ab4f459ee9d1037d7fa962a66ea652b08935539a4f443dc216e82b5717d8bb22 timepps.h
21efede3e94ef5795ea4b1998c8b165d757953b77480c42381794c27d8a6626e gpsd.initd
218a7f044f902070922c45f3b543c9ff6af25be5305648899565c1fbdc0d5da9 gpsd.confd"
sha512sums="082524a7744da5212074123ab7920fe77bfa35f99cb12a900ad7b2718ea563803f988d09d7a063d08784d790c8c7e65503daefce4e6dd6bd1bc77bf580db638f gpsd-3.9.tar.gz
+3fb7d91cb5f00ce52e3ccc6f3c56375410c4257c0be3be6e2253c6ed0c27d49fd0408008379925e96348027b59404e089cb7f64212221e1c950fdf5302044c41 gpsd-use-local-timepps-header.patch
+eb11fc19243d1789016d88eb7645bfe67c46304547781489bf36eb1dd4c252d523681ff835a6488fa0ef62b6b9e2f781c672279f4439f5d5640a3f214a113048 timepps.h
680b891375bb4896cb210ae04a08e1f38cc2127346dbb2942cb61045100adf3ca76909e63e239e840f7676c9869fe1ca19219e2197af6e6ba1354e2ce825001c gpsd.initd
55d4a51f82d445d3ac93b2855132ef4380908ed045feba6298ed1d0b607cd9054b5325c024dc52b370983ebd5d9b377537aee7d7128c97aa22e3075f4134d404 gpsd.confd"