aboutsummaryrefslogtreecommitdiffstats
path: root/main/itstool/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/itstool/APKBUILD')
-rw-r--r--main/itstool/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/main/itstool/APKBUILD b/main/itstool/APKBUILD
index b186f674bc..f40185ac51 100644
--- a/main/itstool/APKBUILD
+++ b/main/itstool/APKBUILD
@@ -1,22 +1,22 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=itstool
pkgver=2.0.4
-pkgrel=0
+pkgrel=1
pkgdesc="ITS-based XML translation tool"
url="http://itstool.org/"
arch="noarch"
license="GPL3+"
-depends="py-libxml2"
+depends="py3-libxml2 python3"
depends_dev=""
makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc"
source="http://files.itstool.org/itstool/itstool-$pkgver.tar.bz2"
-_builddir="$srcdir"/itstool-$pkgver
+builddir="$srcdir"/itstool-$pkgver
prepare() {
local i
- cd "$_builddir"
+ cd "$builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -25,7 +25,7 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,8 +39,13 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
+check() {
+ cd "$builddir"
+ make check
+}
+
sha512sums="f5cfa9c75710f9cc43a61caeb92ca04ec77023bce6fb14d770dda82efde2e5d9050245618c249d309227a3d43555cb1739f5fe680b4a370786ed4631fa9ee4b7 itstool-2.0.4.tar.bz2"