aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-grsec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/linux-grsec/APKBUILD')
-rw-r--r--main/linux-grsec/APKBUILD29
1 files changed, 23 insertions, 6 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 9c21db33e4..681ab85951 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -2,9 +2,9 @@
_flavor=grsec
pkgname=linux-${_flavor}
-pkgver=2.6.37
-_kernver=2.6.37
-pkgrel=0
+pkgver=2.6.35.10
+_kernver=2.6.35
+pkgrel=3
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -13,8 +13,17 @@ options="!strip"
_config=${config:-kernelconfig.${CARCH}}
install=
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
- grsecurity-2.2.1-2.6.37-201102121148.patch
+ http://www.kernel.org/pub/linux/kernel/v2.6/longterm/v${pkgver%.*}/patch-$pkgver.bz2
+ grsecurity-2.2.0-$pkgver-unofficial.patch
+ 0001-xfrm-use-gre-key-as-flow-upper-protocol-info.patch
+ xfrm-fix-gre-key-endianess.patch
+ 0004-arp-flush-arp-cache-on-device-change.patch
+ r8169-add-gro-support.patch
+ 0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
+ 0004-staging-hv-fix-netvsc-sleeping-while-atomic.patch
+
+ setlocalversion.patch
kernelconfig.x86
kernelconfig.x86_64
"
@@ -137,7 +146,15 @@ firmware() {
mv "$pkgdir"/lib/firmware "$subpkgdir"/lib/
}
-md5sums="c8ee37b4fdccdb651e0603d35350b434 linux-2.6.37.tar.bz2
-f56bdcd16fa540cddf075be6842edaaa grsecurity-2.2.1-2.6.37-201102121148.patch
+md5sums="091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
+0741b3219a009fdfc41c766416007fcf patch-2.6.35.10.bz2
+3855791bfc2ee4fff05fc3c783a3a477 grsecurity-2.2.0-2.6.35.10-unofficial.patch
+eed5bd98c0a3b976891c897763eceff5 0001-xfrm-use-gre-key-as-flow-upper-protocol-info.patch
+ea7a7eb2775b71ae5ef24d029a4905bd xfrm-fix-gre-key-endianess.patch
+776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
+139b39da44ecb577275be53d7d365949 r8169-add-gro-support.patch
+648d8b477248f233c318a3b7a961febf 0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
+7cae2d1e1947fa57d7aaaf31c649471c 0004-staging-hv-fix-netvsc-sleeping-while-atomic.patch
+8c224ba0cdf0aa572c7eb50379435be4 setlocalversion.patch
b331582845fd4a702591b67eec47d687 kernelconfig.x86
1f9af7129d5b44eb3c3a60237af4ef70 kernelconfig.x86_64"