aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-posix
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-posix')
-rw-r--r--main/lua-posix/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/lua-posix/APKBUILD b/main/lua-posix/APKBUILD
new file mode 100644
index 0000000000..bb90a0c86f
--- /dev/null
+++ b/main/lua-posix/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-posix
+_name=luaposix
+pkgver=5.1.4
+pkgrel=0
+pkgdesc="POSIX library for Lua"
+url="http://luaforge.net/projects/luaposix/"
+license="MIT"
+depends="lua"
+makedepends="lua-dev"
+source="http://luaforge.net/frs/download.php/3572/luaposix-$pkgver.tar.gz"
+replaces="luaposix"
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ make PREFIX=/usr || return 1
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+md5sums="073019b1a52bfddb94e2521553b47ef5 luaposix-5.1.4.tar.gz"