aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-subprocess/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-subprocess/makefile.patch')
-rw-r--r--main/lua-subprocess/makefile.patch15
1 files changed, 12 insertions, 3 deletions
diff --git a/main/lua-subprocess/makefile.patch b/main/lua-subprocess/makefile.patch
index 7567ca92ce..6ae43ec54f 100644
--- a/main/lua-subprocess/makefile.patch
+++ b/main/lua-subprocess/makefile.patch
@@ -1,6 +1,15 @@
---- ./src/lua-subprocess-20121211/Makefile
-+++ ./Makefile
-@@ -36,7 +36,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -25,7 +25,7 @@ LUA_CFLAGS := $(shell pkg-config --cflags --libs $(lua_package))
+ all: subprocess.so subprocess.html
+
+ subprocess.so: $(SOURCES)
+- $(CC) $(CFLAGS) $(LUA_CFLAGS) -DOS_POSIX -shared -fPIC -o $@ $(SOURCES)
++ $(CC) $(CFLAGS) $(LUA_CFLAGS) -DOS_POSIX -DSHARE_LIOLIB -shared -fPIC -o $@ $(SOURCES)
+
+ subprocess.html: subprocess.txt
+ $(ASCIIDOC) $<
+@@ -36,7 +36,8 @@ clean:
.PHONY: install
install: subprocess.so