aboutsummaryrefslogtreecommitdiffstats
path: root/main/lxterminal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lxterminal/APKBUILD')
-rw-r--r--main/lxterminal/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/main/lxterminal/APKBUILD b/main/lxterminal/APKBUILD
index 534d0bd007..c9b22b5bed 100644
--- a/main/lxterminal/APKBUILD
+++ b/main/lxterminal/APKBUILD
@@ -2,14 +2,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lxterminal
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Desktop-independent VTE-based terminal emulator"
url="http://lxde.org/"
arch="all"
license="GPL2+"
depends=""
makedepends="vte-dev"
-install=""
subpackages="$pkgname-doc $pkgname-lang"
source="https://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.xz
CVE-2016-10369.patch"
@@ -28,14 +27,18 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./src/lxterminal -v
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
sha512sums="05eb6ef8904de9e34a4046ded67d3cece5a93a5b19d37d423f3bde67051a2f0a0e3195443669709a8b732d27246852353a2c9ba59026f9d71f8df6bb1152e37f lxterminal-0.3.0.tar.xz