aboutsummaryrefslogtreecommitdiffstats
path: root/main/nfs-utils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/nfs-utils/APKBUILD')
-rw-r--r--main/nfs-utils/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/main/nfs-utils/APKBUILD b/main/nfs-utils/APKBUILD
index 62add782da..03ef309fa0 100644
--- a/main/nfs-utils/APKBUILD
+++ b/main/nfs-utils/APKBUILD
@@ -35,8 +35,10 @@ prepare() {
patch -p0 -i "${i}" || return 1
done
# fix build on eglibc
- sed -i -e '/^#include <libio.h>/d' \
- support/include/sockaddr.h || return 1
+ if [ "$ALPINE_LIBC" != "eglibc" ]; then
+ sed -i -e '/^#include <libio.h>/d' \
+ support/include/sockaddr.h || return 1
+ fi
# busybox install fix
sed -i 's/--mode 755/-m755/g' \
tools/nfs-iostat/Makefile.am \