aboutsummaryrefslogtreecommitdiffstats
path: root/main/pcre/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/pcre/APKBUILD')
-rw-r--r--main/pcre/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/main/pcre/APKBUILD b/main/pcre/APKBUILD
index 7d9e8896d8..d8b41d5e3a 100644
--- a/main/pcre/APKBUILD
+++ b/main/pcre/APKBUILD
@@ -50,8 +50,11 @@ check() {
cd "$builddir"
# paxmark tests requiring JIT
- ./pcre_jit_test &>/dev/null || ./pcretest &>/dev/null < /dev/null || true
- paxmark -m .libs/lt-pcre_jit_test .libs/lt-pcretest
+ for fn in pcre_jit_test pcretest; do
+ ./$fn &>/dev/null < /dev/null || true
+ [ .libs/lt-$fn ] && paxmark -m .libs/lt-$fn
+ done
+
# skip locale specific tests
sed -i -e 's/do3=yes//g' RunTest