aboutsummaryrefslogtreecommitdiffstats
path: root/main/postgresql
diff options
context:
space:
mode:
Diffstat (limited to 'main/postgresql')
-rw-r--r--main/postgresql/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/postgresql/APKBUILD b/main/postgresql/APKBUILD
index 720effde98..4dd4d2c518 100644
--- a/main/postgresql/APKBUILD
+++ b/main/postgresql/APKBUILD
@@ -78,7 +78,11 @@ build() {
unset PYTHON
}
-_configure() {
+# Note: (...) instead of {...} is NOT a typo!
+_configure() (
+ export CFLAGS="${CFLAGS/-Os/-O2}"
+ export CPPFLAGS="${CPPFLAGS/-Os/-O2}"
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -93,7 +97,7 @@ _configure() {
--with-perl \
--with-python \
--with-tcl
-}
+)
package() {
cd "$builddir"