aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-jwt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-jwt/APKBUILD')
-rw-r--r--main/py3-jwt/APKBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/main/py3-jwt/APKBUILD b/main/py3-jwt/APKBUILD
deleted file mode 100644
index 5ff43079d0..0000000000
--- a/main/py3-jwt/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: Eivind Uggedal <eu@eju.no>
-# Maintainer:
-pkgname=py3-jwt
-_pkgname=PyJWT
-pkgver=1.7.1
-pkgrel=3
-pkgdesc="Python3 JSON Web Token implementation"
-url="https://github.com/jpadilla/pyjwt"
-arch="noarch"
-license="MIT"
-depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-subpackages="$pkgname-cli"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- no-cov-report.patch
- "
-builddir="$srcdir/$_pkgname-$pkgver"
-
-replaces="py-jwt" # Backwards compatibility
-provides="py-jwt=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- cd "$builddir"
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python3 -m pytest .
-}
-
-package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-cli() {
- pkgdesc="$pkgdesc (CLI utility)"
- depends="py3-jwt=$pkgver-r$pkgrel"
-
- mkdir -p "$subpkgdir"/usr/
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
-}
-
-sha512sums="70cd38127b6848933992c8b88303725ef71bfb430ad42eb63247e549b0bdab2a194137349d43ab02a1c97212dbc89f447ee3f0c5403dd14632b8b4b6b9235fc4 PyJWT-1.7.1.tar.gz
-886877c4e40005d254abf6f00389e7e69e1a781119c29da7632e3f475b526e15b2387ab1bc5bade07234932c3a7396c06298540bdd1596a79a4a5e62b64517fc no-cov-report.patch"