aboutsummaryrefslogtreecommitdiffstats
path: root/main/s390-tools/0101-zipl-dont-optimize-size.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/s390-tools/0101-zipl-dont-optimize-size.patch')
-rw-r--r--main/s390-tools/0101-zipl-dont-optimize-size.patch21
1 files changed, 11 insertions, 10 deletions
diff --git a/main/s390-tools/0101-zipl-dont-optimize-size.patch b/main/s390-tools/0101-zipl-dont-optimize-size.patch
index 889dbf4750..6ef8d93e7c 100644
--- a/main/s390-tools/0101-zipl-dont-optimize-size.patch
+++ b/main/s390-tools/0101-zipl-dont-optimize-size.patch
@@ -1,26 +1,27 @@
diff --git a/zipl/boot/Makefile b/zipl/boot/Makefile
-index 83771f1..f221dbf 100644
+index 52b3a23..9dfb146 100644
--- a/zipl/boot/Makefile
+++ b/zipl/boot/Makefile
-@@ -1,6 +1,8 @@
+@@ -1,6 +1,9 @@
# Common definitions
include ../../common.mak
+ALL_CPPFLAGS := $(filter-out -Os,$(ALL_CPPFLAGS))
+ALL_CFLAGS := $(filter-out -Os,$(ALL_CFLAGS))
- CFLAGS_BOOT = -fno-pie -Os -g -I../include -D__ASSEMBLY__ \
++
+ CFLAGS_BOOT = $(NO_PIE_CFLAGS) -Os -g -I../include -D__ASSEMBLY__ \
-DS390_TOOLS_RELEASE=$(S390_TOOLS_RELEASE) \
-fno-builtin -ffreestanding -fno-asynchronous-unwind-tables \
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
-index c526a46..24ec04f 100644
+index 1f39d06..f6bcb97 100644
--- a/zipl/src/Makefile
+++ b/zipl/src/Makefile
-@@ -8,6 +8,8 @@ ALL_CPPFLAGS += -I../include -I../boot -I../../include \
- -DZFCPDUMP_PART_IMAGE=$(ZFCPDUMP_PART_IMAGE) \
- -DZFCPDUMP_PART_RD=$(ZFCPDUMP_PART_RD) \
- -D_FILE_OFFSET_BITS=64 -fno-pie
+@@ -5,6 +5,8 @@ ALL_CPPFLAGS += -I../include -I../boot \
+ -DZFCPDUMP_IMAGE="STRINGIFY($(ZFCPDUMP_DIR)/$(ZFCPDUMP_IMAGE))" \
+ -DZFCPDUMP_INITRD="STRINGIFY($(ZFCPDUMP_DIR)/$(ZFCPDUMP_INITRD))" \
+ -D_FILE_OFFSET_BITS=64 $(NO_PIE_CFLAGS)
+ALL_CPPFLAGS := $(filter-out -Os,$(ALL_CPPFLAGS))
+ALL_CFLAGS := $(filter-out -Os,$(ALL_CFLAGS))
- ALL_LDFLAGS += -Wl,-z,noexecstack -no-pie
+ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
- libs = $(rootdir)/libutil/libutil.a \
+ libs = $(rootdir)/libu2s/libu2s.a \