aboutsummaryrefslogtreecommitdiffstats
path: root/main/strace/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/strace/APKBUILD')
-rw-r--r--main/strace/APKBUILD25
1 files changed, 7 insertions, 18 deletions
diff --git a/main/strace/APKBUILD b/main/strace/APKBUILD
index 2bdce1359c..3bc7826b71 100644
--- a/main/strace/APKBUILD
+++ b/main/strace/APKBUILD
@@ -1,20 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=strace
-pkgver=4.24
+pkgver=4.26
pkgrel=0
pkgdesc="Diagnostic, debugging and instructional userspace tracer"
url="https://strace.io"
-arch="all !s390x"
+arch="all"
# disable checks for now, due to testsuite failure
options="!check"
license="BSD-3-Clause"
depends=""
makedepends="linux-headers autoconf automake gawk"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/strace/$pkgname/archive/v$pkgver.tar.gz
+source="https://github.com/strace/strace/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz
disable-fortify.patch
fix-ppc-pt-regs-collision.patch
nlattr-fix.patch
+ s390-fix-SIGNAL_FRAMESIZE-macro.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -25,19 +26,6 @@ build() {
musl) export CFLAGS="$CFLAGS -Dsigcontext_struct=sigcontext" ;;
esac
- case "$CARCH" in
- s390x)
- # __SIGNAL_FRAMESIZE is defined in asm/sigcontext.h
- # but including it would make conflict with struct sigcontext
- # since we compile with it in musl.
- # Temporarily add this until musl upstream has a proper fix
- # for struct sigcontext.
- export CFLAGS="$CFLAGS -D__SIGNAL_FRAMESIZE=160"
- ;;
- esac
-
- ./bootstrap
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -59,7 +47,8 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="14d5bb8722a3aeb9d1173e6ee040fbad6fd8a66182fd417f5ec699afcd3fc2f03a636a45a529ed1400881db5e766acdd37fd0f3d07da6e651a15abbc5c394c28 strace-4.24.tar.gz
+sha512sums="cce153246802fcdb1547bc11164784066101a2e672e2a264cb742593b559e579aa4bedc749d87fdd1fc2045f4f79b54d419bb50c823074d2cca6f3c75ccf2290 strace-4.26.tar.xz
273b92ebf0069f19bef7ec26c7860e2af7ef01e782255c70ded1ae5e967f8f6bf031ecba96612c6083bf58f46278ba4ab3ec0fb35b08c8c8d668191f97adee52 disable-fortify.patch
b70cee89dd49a2b5a69dc2a56c3a11169d3306e1a73981155188b574486965c034aa52b4ac1c6edff5ef55c9d52f27750acb242fac095a8a9f69689b51b3fad1 fix-ppc-pt-regs-collision.patch
-44b1872cf996caa4970fa6c2875a3a2cffe4a38455e328d968bd7855ef9a05cf41190794dc137bc8667576635f5271057cf0e6cde9a6c7aee66afd1dba9bdba0 nlattr-fix.patch"
+44b1872cf996caa4970fa6c2875a3a2cffe4a38455e328d968bd7855ef9a05cf41190794dc137bc8667576635f5271057cf0e6cde9a6c7aee66afd1dba9bdba0 nlattr-fix.patch
+3cbc2dab39e65f18177bd1d33e1174eb8a00ad3f5972ca7ae4a7b50c31ef90860fe053ee26f3bded4d03628bdaae7b2faca8f13b4ad1f220c3892575f79cbac1 s390-fix-SIGNAL_FRAMESIZE-macro.patch"