aboutsummaryrefslogtreecommitdiffstats
path: root/main/xrdp
diff options
context:
space:
mode:
Diffstat (limited to 'main/xrdp')
-rw-r--r--main/xrdp/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/main/xrdp/APKBUILD b/main/xrdp/APKBUILD
index 62ca56672c..07ced70065 100644
--- a/main/xrdp/APKBUILD
+++ b/main/xrdp/APKBUILD
@@ -23,6 +23,10 @@ source="https://github.com/neutrinolabs/xrdp/releases/download/v$pkgver/xrdp-$pk
builddir="$srcdir/$pkgname-$pkgver"
build() {
+ local _simd_opt=""
+ if [ "$CARCH" = "x86" ]; then
+ _simd_opt="--without-simd"
+ fi
cd "$builddir"
./bootstrap || return 1
./configure \
@@ -34,6 +38,7 @@ build() {
--enable-fuse \
--disable-pam \
--enable-tjpeg \
+ $_simd_opt \
|| return 1
make || return 1
}