aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/opensp/APKBUILD65
-rw-r--r--main/opensp/opensp-1.5-InternalInputSource-fix.patch11
-rw-r--r--main/opensp/opensp-1.5-install.patch19
-rw-r--r--main/opensp/opensp-1.5-wideCharMax-fix.patch10
4 files changed, 105 insertions, 0 deletions
diff --git a/main/opensp/APKBUILD b/main/opensp/APKBUILD
new file mode 100644
index 0000000000..ab05fe2120
--- /dev/null
+++ b/main/opensp/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=opensp
+_realname=OpenSP
+pkgver=1.5.1
+pkgrel=0
+pkgdesc="Implementation of the DSSSL style language"
+url="http://openjade.sourceforge.net"
+arch="all"
+license="custom"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://prdownloads.sourceforge.net/openjade/$_realname-$pkgver.tar.gz
+ opensp-1.5-wideCharMax-fix.patch
+ opensp-1.5-InternalInputSource-fix.patch
+ opensp-1.5-install.patch"
+
+_builddir="$srcdir"/$_realname-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 "$_builddir"/COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING || return 1
+}
+
+md5sums="f46fe0a04b76a4454ec27b7fcc84ec54 OpenSP-1.5.1.tar.gz
+dd5e3d89995dea240c36ce0bad1bddf6 opensp-1.5-wideCharMax-fix.patch
+a8b5378b8501a50f78366bf819176435 opensp-1.5-InternalInputSource-fix.patch
+cfa9bf5850bafea0c2d2ac01a615b929 opensp-1.5-install.patch"
+sha256sums="3f0649840dc3d6ec432e3c8d933b178208f3feccb6db111d22c8995ad07c736b OpenSP-1.5.1.tar.gz
+8f25c56dc58ba6293fe5ef4c860eacfea122d945aa7ecbc5b1ffe54fab62a6c8 opensp-1.5-wideCharMax-fix.patch
+3a1f328c94b49eae2d4c3051b6d2550092d1ebbf3c1ce4399fe97f5adcd7abb1 opensp-1.5-InternalInputSource-fix.patch
+32570cedb02dbaa8fc544cb3706f73c4065b19dcb1dd41fdadc5e7af1fb080fd opensp-1.5-install.patch"
+sha512sums="c89c256d384001d73669181e0894e7ca083bedc3f8bfd77eb7c2d1e9fc5a7c91a33a0bc5ca50491e3a644bb1f58224b027d996e111e5d82d518f5d9f41c8546a OpenSP-1.5.1.tar.gz
+7634358bd5bd2a567a6d449e904e9f95045a83dc45da378adbb551677b25e46c2525484d3c64c31a735acfbacf7af88b348791192ed29610a8166dc69cba962a opensp-1.5-wideCharMax-fix.patch
+4da57ece0246d66bb5d5b71df6f7b01699012a0cc52f6a1cb26af9689277ac9e393b2e3c418ad211e90eba92fe966e2f19d71c611345a69268296be9cfc5e23c opensp-1.5-InternalInputSource-fix.patch
+6d4cddb3c98313643ef7ab57ce154dd8a188b7ea8edc608a62ff25e4f995ab4167be94e40c2a62ae568e22e1ada4bd9bf0c9687e4dfa43dafde4d87e8b73fdf8 opensp-1.5-install.patch"
diff --git a/main/opensp/opensp-1.5-InternalInputSource-fix.patch b/main/opensp/opensp-1.5-InternalInputSource-fix.patch
new file mode 100644
index 0000000000..0e8e393457
--- /dev/null
+++ b/main/opensp/opensp-1.5-InternalInputSource-fix.patch
@@ -0,0 +1,11 @@
+--- a/include/InternalInputSource.h
++++ b/include/InternalInputSource.h
+@@ -34,7 +34,7 @@
+ void pushCharRef(Char ch, const NamedCharRef &);
+ Boolean rewind(Messenger &);
+ const StringC *contents();
+- InternalInputSource *InternalInputSource::asInternalInputSource();
++ InternalInputSource *asInternalInputSource();
+ ~InternalInputSource();
+ private:
+ InternalInputSource(const InternalInputSource &); // undefined
diff --git a/main/opensp/opensp-1.5-install.patch b/main/opensp/opensp-1.5-install.patch
new file mode 100644
index 0000000000..aea321854e
--- /dev/null
+++ b/main/opensp/opensp-1.5-install.patch
@@ -0,0 +1,19 @@
+--- a/intl/Makefile.in
++++ b/intl/Makefile.in
+@@ -153,11 +153,11 @@
+ : ; \
+ fi
+ if test '@USE_INCLUDED_LIBINTL@' = yes; then \
+- test @GLIBC21@ != no || $(mkinstalldirs) $(DESTDIR)$(libdir); \
+- temp=$(DESTDIR)$(libdir)/t-charset.alias; \
+- dest=$(DESTDIR)$(libdir)/charset.alias; \
+- if test -f $(DESTDIR)$(libdir)/charset.alias; then \
+- orig=$(DESTDIR)$(libdir)/charset.alias; \
++ test @GLIBC21@ != no || $(mkinstalldirs) $(DESTDIR)$(datadir); \
++ temp=$(DESTDIR)$(datadir)/t-charset.alias; \
++ dest=$(DESTDIR)$(datadir)/charset.alias; \
++ if test -f $(DESTDIR)$(datadir)/charset.alias; then \
++ orig=$(DESTDIR)$(datadir)/charset.alias; \
+ sed -f ref-add.sed $$orig > $$temp; \
+ $(INSTALL_DATA) $$temp $$dest; \
+ rm -f $$temp; \
diff --git a/main/opensp/opensp-1.5-wideCharMax-fix.patch b/main/opensp/opensp-1.5-wideCharMax-fix.patch
new file mode 100644
index 0000000000..2d45217c3c
--- /dev/null
+++ b/main/opensp/opensp-1.5-wideCharMax-fix.patch
@@ -0,0 +1,10 @@
+--- a/include/RangeMap.cxx
++++ b/include/RangeMap.cxx
+@@ -7,6 +7,7 @@
+ #include "RangeMap.h"
+ #include "ISet.h"
+ #include "types.h"
++#include "constant.h"
+
+ #ifdef SP_NAMESPACE
+ namespace SP_NAMESPACE {