aboutsummaryrefslogtreecommitdiffstats
path: root/testing/anbox/disable-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/anbox/disable-tests.patch')
-rw-r--r--testing/anbox/disable-tests.patch92
1 files changed, 92 insertions, 0 deletions
diff --git a/testing/anbox/disable-tests.patch b/testing/anbox/disable-tests.patch
new file mode 100644
index 0000000000..30d4a3b379
--- /dev/null
+++ b/testing/anbox/disable-tests.patch
@@ -0,0 +1,92 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4ee5b98..8aaa3db 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,7 +1,6 @@
+ project(anbox C CXX)
+ cmake_minimum_required(VERSION 2.8.2)
+
+-include(CTest)
+ include(GNUInstallDirs)
+
+ if (NOT CMAKE_BUILD_TYPE)
+@@ -91,8 +90,6 @@ IF(CMAKE_BUILD_TYPE MATCHES [cC][oO][vV][eE][rR][aA][gG][eE])
+ SET(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -ftest-coverage -fprofile-arcs" )
+ ENDIF(CMAKE_BUILD_TYPE MATCHES [cC][oO][vV][eE][rR][aA][gG][eE])
+
+-find_package(GMock)
+-
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14 -fPIC")
+
+ set(ANBOX_TRANSLATOR_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/anbox/translators)
+@@ -113,7 +110,6 @@ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/anbox/build/config.h.in
+
+ add_subdirectory(external)
+ add_subdirectory(src)
+-add_subdirectory(tests)
+ add_subdirectory(android)
+
+ if (NOT "${HOST_CMAKE_C_COMPILER}" STREQUAL "")
+diff --git a/external/android-emugl/googletest.mk b/external/android-emugl/googletest.mk
+deleted file mode 100644
+index 9d8e5c0..0000000
+--- a/external/android-emugl/googletest.mk
++++ /dev/null
+@@ -1,37 +0,0 @@
+-# This contains common definitions used to define a host module
+-# to link GoogleTest with the EmuGL test programs.
+-#
+-# This is used instead of including external/gtest/Android.mk to
+-# be able to build both the 32-bit and 64-bit binaries while
+-# building a 32-bit only SDK (sdk-eng, sdk_x86-eng, sdk_mips-eng).
+-
+-
+-LOCAL_PATH := $(EMULATOR_GTEST_SOURCES_DIR)
+-
+-common_SRC_FILES := \
+- src/gtest-all.cc \
+- src/gtest_main.cc
+-
+-common_CFLAGS := -O0
+-
+-ifneq (windows,$(BUILD_TARGET_OS))
+- common_LDLIBS += -lpthread
+-endif
+-
+-$(call emugl-begin-host-static-library,libemugl_gtest)
+-LOCAL_SRC_FILES := $(common_SRC_FILES)
+-LOCAL_CFLAGS += $(common_CFLAGS)
+-LOCAL_CPP_EXTENSION := .cc
+-$(call emugl-export,C_INCLUDES,$(LOCAL_PATH)/include)
+-$(call emugl-export,LDLIBS,$(common_LDLIBS))
+-$(call emugl-end-module)
+-
+-$(call emugl-begin-host-static-library,libemugl_gtest_host)
+-LOCAL_SRC_FILES := $(common_SRC_FILES)
+-LOCAL_CFLAGS += $(common_CFLAGS)
+-LOCAL_C_INCLUDES += $(LOCAL_PATH)/include
+-LOCAL_CPP_EXTENSION := .cc
+-$(call emugl-export,C_INCLUDES,$(LOCAL_PATH)/include)
+-$(call emugl-export,LDLIBS,$(common_LDLIBS) -lpthread)
+-LOCAL_HOST_BUILD := true
+-$(call emugl-end-module)
+diff --git a/external/android-emugl/shared/emugl/common/CMakeLists.txt b/external/android-emugl/shared/emugl/common/CMakeLists.txt
+index 09388c6..c4f659d 100644
+--- a/external/android-emugl/shared/emugl/common/CMakeLists.txt
++++ b/external/android-emugl/shared/emugl/common/CMakeLists.txt
+@@ -11,7 +11,6 @@ set(COMMON_SOURCES
+ message_channel.cpp
+ message_channel.h
+ mutex.h
+- mutex_unittest.cpp
+ pod_vector.cpp
+ pod_vector.h
+ scoped_pointer_vector.h
+@@ -25,7 +24,6 @@ set(COMMON_SOURCES
+ thread_pthread.cpp
+ thread_store.cpp
+ thread_store.h
+- thread_unittest.cpp
+ unique_integer_map.h)
+
+ add_library(emugl_common STATIC ${COMMON_SOURCES})