aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apache-mod-auth-kerb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/apache-mod-auth-kerb/APKBUILD')
-rw-r--r--testing/apache-mod-auth-kerb/APKBUILD46
1 files changed, 30 insertions, 16 deletions
diff --git a/testing/apache-mod-auth-kerb/APKBUILD b/testing/apache-mod-auth-kerb/APKBUILD
index 3740f7a86a..9e4dfd66ae 100644
--- a/testing/apache-mod-auth-kerb/APKBUILD
+++ b/testing/apache-mod-auth-kerb/APKBUILD
@@ -3,32 +3,37 @@
pkgname=apache-mod-auth-kerb
_pkgname=mod_auth_kerb
pkgver=5.4
-pkgrel=1
+pkgrel=2
pkgdesc="A Kerberos authentication module for the Apache Http Server"
-url="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/"
+url="http://sourceforge.net/projects/mod_auth_kerb/"
arch="all"
license="custom"
depends="apache2 heimdal"
-makedepends="apache2-dev heimdal-dev samba-dev bash"
+makedepends="apache2-dev heimdal-dev"
source="http://downloads.sourceforge.net/project/modauthkerb/$_pkgname/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz
- mod_auth_kerb.patch
- mod-auth-kerb.conf
- "
+ mod_auth_kerb-5.4-httpd24.patch
+ mod_auth_kerb_compile.patch
+ mod-auth-kerb.conf"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+
prepare() {
- cd $srcdir/$_pkgname-$pkgver
- for i in "$srcdir"/*.patch; do
- [ -f "$i" ] || continue
- msg "Applying $i"
- patch -p1 -i $i || return 1
- done
- sed -i -e 's:^ret.*:ret=`eval "$4" $5 $cppflags $ldflags src/mod_auth_kerb.c $3`:' apxs.sh
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
cd $srcdir/$_pkgname-$pkgver
./configure --prefix=/usr \
- --with-krb5=/usr
- make -j6 || return 1
+ --with-krb5=/usr \
+ --without-krb4 \
+ --with-apache=/usr
+ make -j1 || return 1
}
package() {
@@ -41,5 +46,14 @@ package() {
}
md5sums="642b81763ad3ca81dba359cb952da5e3 mod_auth_kerb-5.4.tar.gz
-3ef3cd9c723f34a2ee7ab350b7c653c9 mod_auth_kerb.patch
+3df80322c5697404b4e9a6ea53a7799a mod_auth_kerb-5.4-httpd24.patch
+9b238dc704dd06cd6c2880d83ca38cc8 mod_auth_kerb_compile.patch
7f9a0976ff101226fae4fd9b811b21a4 mod-auth-kerb.conf"
+sha256sums="690ddd66c6d941e2fa2dada46588329a6f57d0a3b9b2fd9bf055ebc427558265 mod_auth_kerb-5.4.tar.gz
+dffaa66925dab20d2d4b84beb171f0c3ab195a294d422e5ca6e8867e48df24a1 mod_auth_kerb-5.4-httpd24.patch
+bbd036788971a6f9cf97f00870ca83e214f043279ee9fa52c241abc7ece1a587 mod_auth_kerb_compile.patch
+2601c080a091b0fc598e542d754a9a8f5909fadc8f91c4433ed6f5002b36a41d mod-auth-kerb.conf"
+sha512sums="93fdf0e43af1c24e8c8204d09240b708747068ef99dd8d21b45cb4d132d31e6d582d49ea5e23b905f55cb0d4a20b1ecb58de1bcbfdad1d016e536fc622b63214 mod_auth_kerb-5.4.tar.gz
+15100aee410f899fae41d921c1016bc901602871fd387834b4d486521db7ffeb6e917bfcdc5841c8cb2828497e230aa9f04071e36c31ccc8ed5ede3fb0a286dd mod_auth_kerb-5.4-httpd24.patch
+f8fd9cce15593592995a53374a7dbbf6171c4f5e9e82d5bf59953fcfa6fa81cf6890ec4c9ddc2e0963060ea34e98b590f037b1f0274c284085350e6bc4792748 mod_auth_kerb_compile.patch
+b6cfa12dbfd37f98de4d5b23f16462efbfa394d4e9dd6a15772aa18fbec0704c3d9f6e5d242d501a8f1c3091abf893de261115ee54ea31d9d9e0a4d1724473a4 mod-auth-kerb.conf"