aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apache-mod-auth-kerb/mod_auth_kerb.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/apache-mod-auth-kerb/mod_auth_kerb.patch')
-rw-r--r--testing/apache-mod-auth-kerb/mod_auth_kerb.patch24
1 files changed, 13 insertions, 11 deletions
diff --git a/testing/apache-mod-auth-kerb/mod_auth_kerb.patch b/testing/apache-mod-auth-kerb/mod_auth_kerb.patch
index aa0c0a4354..350a393cd4 100644
--- a/testing/apache-mod-auth-kerb/mod_auth_kerb.patch
+++ b/testing/apache-mod-auth-kerb/mod_auth_kerb.patch
@@ -1,11 +1,13 @@
---- mod_auth_kerb-5.4/src/mod_auth_kerb.c 2010-10-04 16:21:22.169285716 +0200
-+++ mod_auth_kerb-5.4.new/src/mod_auth_kerb.c 2010-10-04 16:20:41.584250095 +0200
-@@ -89,6 +89,7 @@
- #include <krb5.h>
- #ifdef HEIMDAL
- # include <gssapi.h>
-+# include <gssapi/gssapi_krb5.h>
- #else
- # include <gssapi/gssapi.h>
- # include <gssapi/gssapi_generic.h>
-
+diff --git a/Makefile.in b/Makefile.in
+index 36f6046..41d4887 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -13,7 +13,7 @@ CFLAGS =
+ all: src/mod_auth_kerb.so
+
+ src/mod_auth_kerb.so: src/mod_auth_kerb.c $(SPNEGO_SRCS)
+- ./apxs.sh "${CPPFLAGS}" "${LDFLAGS}" "${SPNEGO_SRCS}" "${APXS}" "-c" "src/mod_auth_kerb.c"
++ apxs -c ${CPPFLAGS} ${LDFLAGS} mod_auth_kerb.s
+
+ install:
+ ./apxs.sh "${CPPFLAGS}" "${LDFLAGS}" "${SPNEGO_SRCS}" "${APXS}" "-c -i" "src/mod_auth_kerb.c"