aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/bat/APKBUILD')
-rw-r--r--testing/bat/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/bat/APKBUILD b/testing/bat/APKBUILD
index ad2be91834..b134a7f1cf 100644
--- a/testing/bat/APKBUILD
+++ b/testing/bat/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Chloe Kudryavtsev <toast@toastin.space>
# Maintainer: Chloe Kudryavtsev <toast@toastin.space>
pkgname=bat
-pkgver=0.11.0
+pkgver=0.12.1
pkgrel=1
pkgdesc="A cat(1) clone with wings"
url="https://github.com/sharkdp/bat"
arch="x86_64 x86 armhf armv7 aarch64 ppc64le" # limited by rust/cargo
license="Apache-2.0"
depends="less" # Required for RAW-CONTROL-CHARS
-makedepends="cargo"
+makedepends="cargo clang-dev llvm-dev"
+options="net"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/bat/archive/v$pkgver.tar.gz"
@@ -38,4 +39,4 @@ package() {
install -Dm755 target/release/"$pkgname" "$pkgdir"/usr/bin/"$pkgname"
install -Dm644 doc/"$pkgname".1 "$pkgdir"/usr/share/man/man1/"$pkgname".1
}
-sha512sums="29b4ba1a5b42cef43835faec48aca25450ae8ebcc4e3d20933df552462ebd28bb06e1d0245161bf815fce2fcebab547907ac223457320c67eaf8bc053e9d7adf bat-0.11.0.tar.gz"
+sha512sums="74ec162065f1b6f4b1363f107600a7364ba509b5338601b89bf1cd77d6f8290028d87fbf5e2938c6d26f782b0cc55da4161b69183e6748a46bf3644e5e2524b0 bat-0.12.1.tar.gz"