aboutsummaryrefslogtreecommitdiffstats
path: root/testing/blind
diff options
context:
space:
mode:
Diffstat (limited to 'testing/blind')
-rw-r--r--testing/blind/APKBUILD47
-rw-r--r--testing/blind/fix-readall.patch23
-rw-r--r--testing/blind/test.ff.bz2bin0 -> 2403 bytes
3 files changed, 70 insertions, 0 deletions
diff --git a/testing/blind/APKBUILD b/testing/blind/APKBUILD
new file mode 100644
index 0000000000..d983def65e
--- /dev/null
+++ b/testing/blind/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor:Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=blind
+pkgver=1.0
+pkgrel=0
+pkgdesc="blind is a collection of command line video editing utilities"
+url="http://tools.suckless.org/blind/"
+arch="all"
+license="ISC"
+makedepends="ffmpeg ffmpeg-dev imagemagick-dev"
+subpackages="$pkgname-doc"
+source="http://dl.suckless.org/tools/blind-$pkgver.tar.gz
+ fix-readall.patch
+ test.ff.bz2
+"
+builddir="$srcdir/blind-$pkgver"
+
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+check() {
+ cd "$builddir"
+ # Check if blind is operational
+ bunzip2 < "$srcdir/test.ff.bz2" | ./blind-from-image -f > test.bl || return 1
+ ./blind-repeat 15 test.bl | ./blind-flop | ./blind-flip \
+ | ./blind-dissolve | ./blind-to-video 50 -c:v libx264 -preset fast -crf 0 \
+ -pix_fmt yuv444p out.mp4 || return 1
+ rm test.bl out.mp4
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install || return 1
+ cp blind-rotate-* "$pkgdir/usr/bin/"
+}
+
+md5sums="5950b21690b79f44945422db3b108372 blind-1.0.tar.gz
+17ca341f9ec9fa29680e07af1552122d fix-readall.patch
+433d1680f8820eb0b21f143948498fbb test.ff.bz2"
+sha256sums="a9879abf8eac042523177b3fc616cbc4a39888927832994c5daa3ef11c9a66ac blind-1.0.tar.gz
+2a5835b376838062e6858ce5ea0953eefdbe560bfa37e2bed3cb39bdbb3da1b6 fix-readall.patch
+5fdb176ad0653d3d6b3ce332deeaeff01a69ea0fed4cd9967b41a73a47cec19a test.ff.bz2"
+sha512sums="5543efa9ff9b6931288c5d987ea8a73e2aed695a979b9f326d2f2d6d2352170ef37bd017997a43a0b425d8ae68e0b981d22b4dccc0140e4fdd6890058d020291 blind-1.0.tar.gz
+cc5ef6e5d84202a4194b4858177d7385674208338de5ce68918838d162ad57bc89f738484bda3bdb2e121fb75029fe74bbf460e92d0ba6b3a678883f151002f9 fix-readall.patch
+0834032e1e416824883658478b8cc2821df9b41cf4f169f471df0476c35dfe4a6bcc9c103e5522e54d7f820f77710e3215c691fa39311f6be3310cb1745e2b73 test.ff.bz2"
diff --git a/testing/blind/fix-readall.patch b/testing/blind/fix-readall.patch
new file mode 100644
index 0000000000..1e5ebfdacb
--- /dev/null
+++ b/testing/blind/fix-readall.patch
@@ -0,0 +1,23 @@
+---
+ src/util.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/util.c b/src/util.c
+index 6c1bd0a..8967392 100644
+--- a/src/util.c
++++ b/src/util.c
+@@ -136,9 +136,9 @@ readall(int fd, void *buf, size_t n)
+ return -1;
+ if (r == 0)
+ break;
+- r += (size_t)r;
++ ptr += (size_t)r;
+ }
+- return r;
++ return ptr;
+ }
+
+ int
+--
+2.11.1
+
diff --git a/testing/blind/test.ff.bz2 b/testing/blind/test.ff.bz2
new file mode 100644
index 0000000000..8469a22452
--- /dev/null
+++ b/testing/blind/test.ff.bz2
Binary files differ