aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cloudi/cloudi.initd
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cloudi/cloudi.initd')
-rw-r--r--testing/cloudi/cloudi.initd35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/cloudi/cloudi.initd b/testing/cloudi/cloudi.initd
new file mode 100644
index 0000000000..8fc9ad1377
--- /dev/null
+++ b/testing/cloudi/cloudi.initd
@@ -0,0 +1,35 @@
+#!/sbin/openrc-run
+
+# Justification for the script use here exists in the port's APKBUILD file.
+
+name=cloudi
+command=/usr/sbin/cloudi
+command_args=""
+command_background="false"
+
+description="CloudI is an open-source private cloud computing framework for efficient, scalable, and stable soft-realtime event processing."
+
+depend() {
+ need localmount
+ need net
+ after firewall
+}
+start() {
+ $command start
+}
+stop() {
+ $command stop
+}
+restart() {
+ $command restart
+}
+status() {
+ $command test
+ if [ $? -eq 0 ]; then
+ einfo "status: started"
+ return 0
+ else
+ einfo "status: stopped"
+ return 3
+ fi
+}