aboutsummaryrefslogtreecommitdiffstats
path: root/testing/coova-chilli/coova-chilli-ssl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/coova-chilli/coova-chilli-ssl.patch')
-rw-r--r--testing/coova-chilli/coova-chilli-ssl.patch26
1 files changed, 15 insertions, 11 deletions
diff --git a/testing/coova-chilli/coova-chilli-ssl.patch b/testing/coova-chilli/coova-chilli-ssl.patch
index 618b90a60a..1567c96cb3 100644
--- a/testing/coova-chilli/coova-chilli-ssl.patch
+++ b/testing/coova-chilli/coova-chilli-ssl.patch
@@ -1,17 +1,21 @@
-diff -ru a/src/Makefile.am b/src/Makefile.am
---- a/src/Makefile.am 2009-10-15 09:15:00.000000000 +0000
-+++ b/src/Makefile.am 2009-10-15 09:17:20.000000000 +0000
-@@ -20,6 +20,7 @@
- chilli.h options.h util.c garden.c garden.h \
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -13,7 +13,8 @@
+ chilli.h options.h util.c garden.c garden.h ssl.h ssl.c \
dns.c dns.h session.c session.h limits.h pkt.h pkt.c \
- chksum.c net.h net.c ms_chap.c options.c
+ chksum.c net.h net.c ms_chap.c options.c statusfile.c \
+-conn.h conn.c
++conn.h conn.c
+libchilli_la_LIBADD = $(LIBOPENSSL)
- # AM_LDFLAGS = -lchilli
-
-@@ -32,4 +33,4 @@
- chilli_dog_SOURCES = main-dog.c
+ AM_CFLAGS = -D_GNU_SOURCE -Wall -fno-builtin -fno-strict-aliasing \
+ -O2 -fomit-frame-pointer -funroll-loops -pipe \
+@@ -33,7 +34,7 @@
#test_radius_SOURCES = test-radius.c
+ #test_dhcp_SOURCES = test-dhcp.c
--LDADD = libchilli.la $(top_builddir)/bstring/libbstring.la
+-LDADD = libchilli.la $(top_builddir)/bstring/libbstring.la ${LIBRT}
+LDADD = libchilli.la $(top_builddir)/bstring/libbstring.la $(LIBOPENSSL)
+
+ if WITH_OPENSSL
+ LDADD += ${LIBSSL}