aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dc3dd
diff options
context:
space:
mode:
Diffstat (limited to 'testing/dc3dd')
-rw-r--r--testing/dc3dd/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/dc3dd/APKBUILD b/testing/dc3dd/APKBUILD
new file mode 100644
index 0000000000..7a31ce4325
--- /dev/null
+++ b/testing/dc3dd/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=dc3dd
+pkgver=7.0.0
+pkgrel=0
+pkgdesc="Patched version of GNU dd for use in computer forensics"
+url="http://dc3dd.sourceforge.net/"
+arch="all"
+license="GPL2+ and GPL3+"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/dc3dd/dc3dd-$pkgver.tar.gz"
+_builddir="$srcdir"/dc3dd-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ rm po/*.gmo
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="37e00481273b4c4ae2ebb430e5fb80af dc3dd-7.0.0.tar.gz"