aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dhcp-probe/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/dhcp-probe/APKBUILD')
-rw-r--r--testing/dhcp-probe/APKBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/testing/dhcp-probe/APKBUILD b/testing/dhcp-probe/APKBUILD
index 6e1d12c7a0..58ded1a2bd 100644
--- a/testing/dhcp-probe/APKBUILD
+++ b/testing/dhcp-probe/APKBUILD
@@ -3,7 +3,7 @@
pkgname=dhcp-probe
_pkgname=dhcp_probe
pkgver=1.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Allows network administrators to make calculations that will assist in subnetting a network"
url="http://www.net.princeton.edu/software/dhcp_probe/"
arch="all"
@@ -13,7 +13,9 @@ depends_dev="libnet-dev libpcap-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc"
-source="http://www.net.princeton.edu/software/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="http://www.net.princeton.edu/software/$_pkgname/$_pkgname-$pkgver.tar.gz
+ $pkgname.initd
+ $pkgname.confd"
_builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
local i
@@ -32,5 +34,14 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
+ mkdir -p "$srcdir"/etc/dhcp-probe
+ install -Dm755 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname || return 1
+ install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname || return 1
+ install -Dm755 "$_builddir"/extras/dhcp_probe.cf.sample "$pkgdir"/etc/dhcp-probe/dhcp_probe.cf || return 1
+ for f in dhcp_probe_notify dhcp_probe_notify2 mail-throttled; do
+ install -Dm755 "$_builddir"/extras/$f "$pkgdir"/etc/dhcp-probe/$f || return 1
+ done
}
-md5sums="8067e696fbd88120bdcc2ffef4b64da2 dhcp_probe-1.3.0.tar.gz"
+md5sums="8067e696fbd88120bdcc2ffef4b64da2 dhcp_probe-1.3.0.tar.gz
+d69a227cd436b60f918633a7f7ac7034 dhcp-probe.initd
+1ffbda883f84af0daf5a2992370de643 dhcp-probe.confd"