aboutsummaryrefslogtreecommitdiffstats
path: root/testing/geos/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/geos/APKBUILD')
-rw-r--r--testing/geos/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/testing/geos/APKBUILD b/testing/geos/APKBUILD
index 6e46436817..ded077193c 100644
--- a/testing/geos/APKBUILD
+++ b/testing/geos/APKBUILD
@@ -26,6 +26,13 @@ build() {
case "$CARCH" in
aarch64*|ppc64le) CXXFLAGS="$CXXFLAGS -ffp-contract=off" ;;
esac
+
+ # fix build on armhf and armv7 with info from
+ # https://trac.osgeo.org/geos/ticket/993
+ case "$CARCH" in
+ armhf|armv7) CXXFLAGS="$CXXFLAGS -DDISABLE_GEOS_INLINE=ON" ;;
+ esac
+
./configure \
--build=$CBUILD \
--host=$CHOST \