aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hexinject/fix-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hexinject/fix-build.patch')
-rw-r--r--testing/hexinject/fix-build.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/testing/hexinject/fix-build.patch b/testing/hexinject/fix-build.patch
new file mode 100644
index 0000000000..cce8b1e4f3
--- /dev/null
+++ b/testing/hexinject/fix-build.patch
@@ -0,0 +1,15 @@
+--- hexinject/Makefile.orig 2017-08-29 07:29:31.430661450 +0000
++++ hexinject/Makefile 2017-08-29 07:29:53.634411237 +0000
+@@ -3,9 +3,9 @@
+ LDFLAGS = -lpcap
+
+ all:
+- $(CC) $(CFLAGS) $(LDFLAGS) -o hexinject hexinject.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o prettypacket prettypacket.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o hex2raw hex2raw.c
++ $(CC) $(CFLAGS) -o hexinject hexinject.c $(LDFLAGS)
++ $(CC) $(CFLAGS) -o prettypacket prettypacket.c $(LDFLAGS)
++ $(CC) $(CFLAGS) -o hex2raw hex2raw.c $(LDFLAGS)
+
+ clean:
+ rm -f hexinject prettypacket hex2raw *~