aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kdecoration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kdecoration/APKBUILD')
-rw-r--r--testing/kdecoration/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/kdecoration/APKBUILD b/testing/kdecoration/APKBUILD
new file mode 100644
index 0000000000..061c890e8a
--- /dev/null
+++ b/testing/kdecoration/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kdecoration
+pkgver=5.16.1
+pkgrel=0
+pkgdesc="Plugin based library to create window decorations"
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+depends_dev="qt5-qtbase-dev ki18n-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+options="!check" # Fails due to requiring running X11
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="510c6c81186199c0abcf24514454d45f7a01048dacdf7f48b9e52533a0d7a76f983d4dd6c8593ae74c8f4b6819b35cadc11a0682844aab9233cc60821f74491a kdecoration-5.16.1.tar.xz"