aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libzookeeper/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libzookeeper/APKBUILD')
-rw-r--r--testing/libzookeeper/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/libzookeeper/APKBUILD b/testing/libzookeeper/APKBUILD
new file mode 100644
index 0000000000..831c60a67c
--- /dev/null
+++ b/testing/libzookeeper/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Maciej Klak <klak.maciej@gmail.com>
+# Maintainer: Maciej Klak <klak.maciej@gmail.com>
+pkgname=libzookeeper
+pkgver=3.4.13
+pkgrel=0
+pkgdesc="The Apache ZooKeeper system for distributed coordination is a high-performance service for building distributed applications."
+url="https://zookeeper.apache.org"
+arch="all"
+license="Apache License"
+subpackages="$pkgname-dev"
+options="!check" # No test suite
+source="http://www-eu.apache.org/dist/zookeeper/zookeeper-$pkgver/zookeeper-$pkgver.tar.gz"
+builddir="$srcdir/zookeeper-$pkgver/src/c"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3481bd19945d80848f81d9dc2896a682ae8b62269b8164ffbae532e55aa4219961403e0208c8e72cf784605eae436d70ddae2b26e0deba0f1f84c74188c32c0a zookeeper-3.4.13.tar.gz"