aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lua-fun
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lua-fun')
-rw-r--r--testing/lua-fun/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/lua-fun/APKBUILD b/testing/lua-fun/APKBUILD
new file mode 100644
index 0000000000..1db3a7a21a
--- /dev/null
+++ b/testing/lua-fun/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Michael Zuo <muh.muhten@gmail.com>
+# Maintainer: Michael Zuo <muh.muhten@gmail.com>
+pkgname=lua-fun
+pkgver=0.1.3
+_luaversions="5.1 5.2 5.3"
+pkgrel=0
+pkgdesc="Functional programming library"
+# "Lua Fun is a high-performance functional programming library for Lua
+# designed with LuaJIT's trace compiler in mind."
+url="http://rtsisyk.github.io/luafun/"
+arch="noarch"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/rtsisyk/luafun/archive/$pkgver.tar.gz"
+
+for _v in $_luaversions; do
+ subpackages="$subpackages lua$_v-${pkgname#*lua-}:split_${_v/./_}"
+ eval "split_${_v/./_}() { _split $_v; }"
+done
+
+_builddir="$srcdir/luafun-$pkgver"
+build() {
+ :
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_split() {
+ install_if="lua$1 $pkgname=$pkgver-r$pkgrel"
+ pkgdesc="$pkgdesc for Lua $1"
+
+ cd "$_builddir"
+ install -Dm644 fun.lua "$subpkgdir/usr/share/lua/$1/fun.lua" || return 1
+}
+
+md5sums="ab774af3d0dea06656039e5fc3ee86ad lua-fun-0.1.3.tar.gz"
+sha256sums="b17a139e94a150595ffce09e800035f71fe9e0631b54b6fbf193dfe57255e4b7 lua-fun-0.1.3.tar.gz"
+sha512sums="1959c22453a6f431e4f4ee1ca1e6001c126f8857e00b128e5303049fd574150a68b71490503356f11fefcbd0ef7fbac7b0ae7c182a395ad0c92d2047dfac0662 lua-fun-0.1.3.tar.gz"