aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lua-linotify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lua-linotify/APKBUILD')
-rw-r--r--testing/lua-linotify/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/lua-linotify/APKBUILD b/testing/lua-linotify/APKBUILD
new file mode 100644
index 0000000000..782cda30f7
--- /dev/null
+++ b/testing/lua-linotify/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=lua-linotify
+pkgver=0.4
+pkgrel=0
+pkgdesc="Inotify bindings for Lua"
+url="https://github.com/hoelzro/linotify"
+arch="all"
+license="MIT"
+depends=""
+makedepends=""
+install=""
+subpackages=""
+source="linotify-$pkgver.tar.gz::https://github.com/hoelzro/linotify/archive/$pkgver.tar.gz
+ makefile.patch
+ "
+builddir="$srcdir/linotify-$pkgver"
+
+_luaversions="5.1 5.2 5.3"
+for _v in $_luaversions; do
+ makedepends="$makedepends lua$_v-dev"
+ subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
+done
+
+prepare() {
+ default_prepare
+
+ local lver; for lver in $_luaversions; do
+ cp -r "$builddir" "$builddir-$lver"
+ done
+}
+
+build() {
+ local lver; for lver in $_luaversions; do
+ msg "Building for Lua $lver..."
+ make LUAVER=$lver -C "$builddir-$lver"
+ done
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_subpackage() {
+ local lver="${subpkgname:3:3}"
+ pkgdesc="$pkgdesc (for Lua $lver)"
+ depends="lua$lver"
+ install_if="$pkgname=$pkgver-r$pkgrel lua$lver"
+
+ cd "$builddir-$lver"
+ make LUAVER=$lver PREFIX="/usr" DESTDIR="$subpkgdir" install
+}
+
+sha512sums="8024b32ffcb8ce696786bf15f5b61978e511d6484e3817550fc0e49b1dbebb3f3db9d4b2ced8e772a65b31616102a03161dbc91e3efb4082ccea63b7269ac5d8 linotify-0.4.tar.gz
+d2729c6124c0119d0933c6b563747795be6ed830c539ae839ba4724412e535cabc53457b81a578fa7c551e4e1894428868b7a79d9d7299675d74e0fbae033b5a makefile.patch"