aboutsummaryrefslogtreecommitdiffstats
path: root/testing/micropython/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/micropython/APKBUILD')
-rw-r--r--testing/micropython/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/testing/micropython/APKBUILD b/testing/micropython/APKBUILD
index 34a7da644c..05bbb3330d 100644
--- a/testing/micropython/APKBUILD
+++ b/testing/micropython/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Marian <marian.buschsieweke@ovgu.de>
# Maintainer: Marian <marian.buschsieweke@ovgu.de>
pkgname=micropython
-pkgver=1.9.2
+pkgver=1.9.3
pkgrel=0
pkgdesc="A lean and efficient Python implementation for MCUs and constrained systems"
url="http://www.micropython.org/"
@@ -14,14 +14,13 @@ depends=""
makedepends="libffi-dev python3"
subpackages="$pkgname-cross"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz
- 0000-unix-mpconfigport.patch
- python3.patch
+ 0000-unix-mpconfigport.patch
"
builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
cd "$builddir"
- make -C unix PYTHON=python3
+ make -C ports/unix PYTHON=python3
}
check() {
@@ -30,13 +29,13 @@ check() {
# ffi callback fails on kernel with PaX
rm tests/unix/ffi_callback.py
- make -C unix test PYTHON=python3
+ make -C ports/unix test PYTHON=python3
}
package() {
cd "$builddir"
mkdir -p "${pkgdir}/usr/bin"
- install -m755 unix/micropython "${pkgdir}/usr/bin/micropython"
+ install -m755 ports/unix/micropython "${pkgdir}/usr/bin/micropython"
}
cross() {
@@ -46,6 +45,5 @@ cross() {
install -m755 mpy-cross/mpy-cross "${subpkgdir}/usr/bin/mpy-cross"
}
-sha512sums="f9caa268766e1e312d845d2338f15d9e362cec75d8c2d99d2c32b42aef6e8db018dc58631781fb3da61914d850151d36070ef5f005f432029fedd5ac96cae4a6 micropython-1.9.2.tar.gz
-636914a6347b57390de6fb45ff389f751c312b2959f30748c7ce08a4ea95b1eac804812255677aceb24dd5e9f1c9e5f4db9fa4c50f945f4da2623217b45ee360 0000-unix-mpconfigport.patch
-66ca172a6e9f4866e733e6c9303882dbb5f5729ffc685e0ba200010bacb8d5014527efd82da4c2ab62266e0816917758ae8e6089fb575ec31c3dc4441909343f python3.patch"
+sha512sums="d276dc9a300e400f5fd5742bfc8c641c0af2d3b7f3ae9221b811100d85e9c2a6c6c558775183c58dd4be39a31284c596c0e98c9bb2c8e60ce4cf0d83434d0a47 micropython-1.9.3.tar.gz
+4c1de6a6477453e846998565402c69d1dd716cf692a3bb55aa16b6991722a94d8364c05f0603b981a7dd9e9af577a3f46910a60d501513af547ebbf3ed574711 0000-unix-mpconfigport.patch"