aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mod_auth_cas/openssl-1.1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mod_auth_cas/openssl-1.1.patch')
-rw-r--r--testing/mod_auth_cas/openssl-1.1.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/testing/mod_auth_cas/openssl-1.1.patch b/testing/mod_auth_cas/openssl-1.1.patch
new file mode 100644
index 0000000000..66c8802cfc
--- /dev/null
+++ b/testing/mod_auth_cas/openssl-1.1.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 72644f1..7d0f21d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -131,7 +131,7 @@ AC_SUBST(TEST_COVERAGE_CFLAGS)
+ AX_CHECK_OPENSSL
+
+ AC_CHECK_LIB([crypto],[CRYPTO_new_ex_data], [], [AC_MSG_ERROR([OpenSSL libraries required])])
+-AC_CHECK_LIB([ssl],[SSL_library_init], [], [AC_MSG_ERROR([OpenSSL libraries required])])
++AC_CHECK_LIB([ssl],[OPENSSL_init_ssl], [], [AC_MSG_ERROR([OpenSSL libraries required])])
+
+ AC_CHECK_HEADERS([openssl/crypto.h openssl/x509.h openssl/pem.h openssl/ssl.h openssl/err.h],[],[AC_MSG_ERROR([OpenSSL headers required])])
+