aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ospd-ikeprobe/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ospd-ikeprobe/APKBUILD')
-rw-r--r--testing/ospd-ikeprobe/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/ospd-ikeprobe/APKBUILD b/testing/ospd-ikeprobe/APKBUILD
new file mode 100644
index 0000000000..a8b086edd0
--- /dev/null
+++ b/testing/ospd-ikeprobe/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-ikeprobe
+pkgver=1.0b1
+pkgrel=4
+_pkgid=2204
+pkgdesc="OSP server implementation to allow OpenVAS to remotely control a ikeprobe scanner"
+url="http://www.openvas.org/"
+arch="noarch"
+license="GPL"
+depends="python3 ospd"
+makedepends="cmake python3-dev py3-setuptools"
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="567b2100ab42d7effe8fb47890a3c05fb7066ef97e29f2c723a3f29fd58addac220a91dda01804e997eec126905d43d59621b7318bfa02487ed789e228fe8660 ospd-ikeprobe-1.0b1.tar.gz"